85-87 442

Results 1 to 5 of 5

Thread: Instrument Cluster Problem

  1. #1
    Member Visceron's Avatar
    Join Date
    Jun 2013
    Location
    United States
    Posts
    64
    Rep Power
    6

    Default Instrument Cluster Problem

    My Instrument Cluster doesn't work most of the time. The RPM does (even though bouncy as all hell) the other instruments (oil, fuel, elec etc.) dont come on everytime. It's hit or miss when I turn on the car and the gauges are most of the time not working, but every 5th or 6th time, they work. Where should I look first?

  2. #2
    Administrator 88hurstolds's Avatar
    Join Date
    Jun 2008
    Location
    Chicago, IL
    Posts
    1,251
    Rep Power
    10

    Default

    You have a bad ground.
    The contacts should be cleaned and fluffed up a little in order to get better contact.
    Also make sure the nuts on the circuit board are not loose.
    Lightning Rods repair service:CLICK HERE
    Seller Feedback:CLICK HERE
    1988 H/OCA Advisor
    88 H/O #1 of 4
    88 CSC White/Claret - T-tops
    88 H/O Triple Black
    87 442 Black/Gray - T-tops
    85 442 White/Blue - T-tops
    85 442 White/Blue - T-tops
    85 442 White/Claret - T-tops
    85 442 White/Sage
    84 H/O Aero Commemorative #2199 - Sunroof
    83 H/O #2400 Sand Gray - Sunroof
    83 H/O #1607 Sand Gray - T-tops
    83 H/O #727 Maple
    "Keep them Rockets lit!"

  3. #3
    Member Visceron's Avatar
    Join Date
    Jun 2013
    Location
    United States
    Posts
    64
    Rep Power
    6

    Default

    88, I have no idea how you dont get bored being the only one replying to my questions. What specific ground locations should I target?

  4. #4
    Member Visceron's Avatar
    Join Date
    Jun 2013
    Location
    United States
    Posts
    64
    Rep Power
    6

    Default

    Once again you have all the answers 88 Hurst!! I took it all apart, nscrewed the 5 little screws on the back and they had corossion. I used my needle nose as a file and rubbed off the corrosion on the nuts and cleaned up the circuit board side and my gauges work everytime!

  5. #5
    Administrator 88hurstolds's Avatar
    Join Date
    Jun 2008
    Location
    Chicago, IL
    Posts
    1,251
    Rep Power
    10

    Default

    Sweet!
    Lightning Rods repair service:CLICK HERE
    Seller Feedback:CLICK HERE
    1988 H/OCA Advisor
    88 H/O #1 of 4
    88 CSC White/Claret - T-tops
    88 H/O Triple Black
    87 442 Black/Gray - T-tops
    85 442 White/Blue - T-tops
    85 442 White/Blue - T-tops
    85 442 White/Claret - T-tops
    85 442 White/Sage
    84 H/O Aero Commemorative #2199 - Sunroof
    83 H/O #2400 Sand Gray - Sunroof
    83 H/O #1607 Sand Gray - T-tops
    83 H/O #727 Maple
    "Keep them Rockets lit!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •