Announcement

Collapse
No announcement yet.

All around LED's - No Turn Signals

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • All around LED's - No Turn Signals

    I recently replaced my front turn signals to LED's (I replaced all 4 rear tail lights with LED's with no problem) and now my turn signals do not work. I hit the emergency lights and they flash, but when I hit the turn signal, the signal in the dash illuminates to about 40% of what it should be in brightness and I do not get a flickering turn signal or any lights working. Do I need to replace my flasher or is there an easy work around trick for it?

  • #2
    Originally posted by Visceron View Post
    I recently replaced my front turn signals to LED's (I replaced all 4 rear tail lights with LED's with no problem) and now my turn signals do not work. I hit the emergency lights and they flash, but when I hit the turn signal, the signal in the dash illuminates to about 40% of what it should be in brightness and I do not get a flickering turn signal or any lights working. Do I need to replace my flasher or is there an easy work around trick for it?
    It's not the flasher, might be the bulbs are not properly installed or the turn signal switch in the column.
    Most likely its the wrong bulbs or something along those lines... work backwards, try installing the old ones.
    Best to get a chassis service manual off of eBay with a wire diagram.
    Or try these:
    http://www.gbodyolds.com/forum/showt...ing-Schematics
    Lightning Rods repair service:CLICK HERE
    Seller Feedback:CLICK HERE
    1988 H/OCA Advisor
    88 H/O #1 of 4
    88 CSC White/Claret - T-tops
    88 H/O Triple Black
    87 442 Black/Gray - T-tops
    85 442 White/Blue - T-tops
    85 442 White/Blue - T-tops
    85 442 White/Claret - T-tops
    85 442 White/Sage
    84 H/O Aero Commemorative #2199 - Sunroof
    83 H/O #2400 Sand Gray - Sunroof
    83 H/O #1607 Sand Gray - T-tops
    83 H/O #727 Maple
    "Keep them Rockets lit!"

    Comment


    • #3
      I've noticed that the turn signals do not work when I have my parking or head lights turned on. I was told to get a resistor or something that balances out the wattage. I was also told that the led's draw less wattage.

      Comment


      • #4
        From what I have gathered, I need to put something in line with the turn signals to give them enough power to blink. Since the LED's draw less wattage, I need to get something to correct that.

        Comment

        Working...
        X